Requirements

Events Booking is a Joomla extension, so you need to have a website built on Joomla CMS to use the extension. Please look at https://www.joomla.org/about-joomla/technical-requirements.html to see technial requirement for your server. Events Booking only works with Joomla 2.5 and Joomla 3.x, it doesn't work with Joomla 1.5.

Beside generic requirement with a Joomla website, Events Booking also requires some additional requirements below:

  1. PHP 5.3.x+. Joomla 3.x requires PHP 5.3.10+ already, so if you are using Joomla 3, you won't have to worry about this requirement. However, if you are using Joomla 2.5, make sure your server is running PHP 5.3.x+ (on some Joomla 2.5 websites, we still see the server running PHP 5.2.17). If that's the case with your site, please contact your hosting provider, ask them to change settings for your hosting account to use Joomla 5.3.x+.
  2. If you use a credit card based payment plugin (for example, Paypal Pro, Authorize.net, Eway, NAB Transact...), customers will enter credit card information directly on your site for processing payment, so your site should have an SSL certificate installed so that the payment process will be secure. Without an SSL certificate, Events Booking still works well, however, in this case, the credit card data which customers enter on your site for processing payment won't be encrypted when it is transfered over internet, and it will be inscure.